2017-09-22 8 views
5

जब JDK 9. जोड़ने के लिए यह JDK 8 के साथ काम कर रहा है की कोशिश कर रहा निम्न त्रुटि हो रही है, लेकिन नहीं JDK 9.ग्रहण ऑक्सीजन - मुसीबत जोड़ने JRE/JDK 9

कृपया सलाह दें।

Error with JDK9

+0

यह *** बस *** बाहर आया। कुछ समय दें। उस तरफ ... यह जावा 8 के साथ समान पथों के साथ काम करता है (इसलिए जेआरई होम भी सी: \ प्रोग्राम फ़ाइलें \ जावा \ jdk-8) है? क्या जावा 8 फ़ोल्डर और जावा 9 फ़ोल्डर के बीच अंतर हैं? – Makoto

+0

जावा 8 फ़ोल्डर है: सी: \ प्रोग्राम फ़ाइलें \ जावा \ jdk1.8.0_144 –

+0

मैं 4.7.1 का उपयोग कर रहा हूं और मैं एक जेडीके 9 नहीं जोड़ सकता। :( –

उत्तर

1

ऑक्सीजन के लिए जावा 9 समर्थन जोड़ें। इसे link पढ़ें। जावा 9 स्थिर रिलीज केवल आज लॉन्च किया गया है। तो यह अभी भी बेस ऑक्सीजन पैकेज में उपलब्ध नहीं है। यदि आप एक्लिप्स के साथ जावा 9 का उपयोग करने में जल्दी में हैं, तो आप बाजार स्थान से समर्थन पैच डाउनलोड कर सकते हैं।

+0

समर्थन ऑक्सीजन .1 (4.7.1) में एकीकृत किया जाएगा जो अगले कुछ दिनों में जारी किया जाना चाहिए। –

+0

4.7.1 बाहर है और मुझे एक ही समस्या का सामना करना पड़ रहा है। जेआरई/जेडीके 9 :( –

+0

बॉक्स समर्थन में से 4.7.1 ** ** ** है, 4.7.1 में नहीं। – alostale

0

मुझे एक ही समस्या थी। मैंने नवीनतम ग्रहण डाउनलोड किया, 4.7.1, और जेआरई/जेडीके 9 नहीं जोड़ सका।

यही समस्या मैंने हल करने के लिए किया: सहायता -> अपडेट के लिए जांचें। तीन अपडेट पाए गए। मैंने पहला, "आरसीपी और आरएपी डेवलपर्स के लिए ग्रहण" स्थापित किया, और voilà!

मैं अंत में एक जेआरई/जेडीके 9 जोड़ सकता हूं। यह "जोड़ें ..." और "खोज ..." बटन दोनों के माध्यम से काम करता है।

1

का समर्थन करता है कि जावा 9 v4.7.1a (ध्यान दें "एक" अंत में)
The release notes are here
यह उपलब्ध 11 अक्टूबर
के बाद से यह संस्करण भी JUnit 5
आप download it here as before कर सकते हैं के लिए समर्थन शामिल है ग्रहण के सरकारी संस्करण

संबंधित मुद्दे