2017-12-21 66 views
11

नहीं मिल रहा है मैं कोणीय पर काम कर रहा हूं और मैं बैक एंड के लिए फायरबेस का उपयोग करना चाहता था। मैं इस अनुदेश https://github.com/angular/angularfire2/blob/master/docs/install-and-setup.md निम्नलिखित कोणीय आग स्थापित यहाँ मेरी package.jsonमॉड्यूल '@ फायरबेस/ऐप-प्रकार/निजी'

"angularfire2": "^5.0.0-rc.4", 
"firebase": "^4.8.1", 

मैं इस समस्या का सामना करना पड़ रहा है। क्या कोई मुझे इस बारे में सहायता कर सकता है?

ERROR in node_modules/@firebase/database/dist/esm/src/api/Database.d.ts(4,33): error TS2307: Cannot find module '@firebase/app-types/private'. node_modules/@firebase/database/dist/esm/src/core/AuthTokenProvider.d.ts(17,39): error TS2307: Cannot find module '@firebase/app-types/private'. 
+0

यह भी देखें [angularfire2 # 1387] (https: // github।कॉम/कोणीय/angularfire2/मुद्दों/1387) और [फायरबेस-जेएस-एसडीके # 388] (https://github.com/firebase/firebase-js-sdk/issues/388) – Kato

उत्तर

34

अपने फ़ायरबेस संस्करण को 4.8.0 पर बदलें। टाइप परिभाषाओं में एक मुद्दा था और यह अब 4.8.0 से 4.8.1 तक अपडेट करने के बाद काम नहीं करता है।

तो package.json फ़ाइल में संस्करण को बदलें। हटाने ^

"angularfire2": "^5.0.0-rc.4", 
"firebase": "4.8.0", 

अब npm install आदेश पर अमल। यह 4.8.0 संस्करण

अधिक जानकारी के लिए this और this देखें।

+0

हाँ जो आपको धन्यवाद देता है – Solomon

+0

@ सोलोमन कोई समस्या नहीं :) –

+0

@SachilaRanawaka मैं संस्करण कैसे बदलूं? – Ivantha

12

नवीनतम एनपीएम फ़ायरबेस पैकेज (v4.8.1) में कोई समस्या है।

इस समस्या को ठीक करने के लिए, अपने टर्मिनल में। प्रकार

npm uninstall --save firebase 

अब, अपने package.json फ़ाइल खोलें। वहाँ, आप पाएँगे:

"angularfire2": "^5.0.0-rc.4", 

इस रेखा के नीचे जोड़ने के एक इस लाइन (ध्यान दें, यहाँ कोई कैरट (^) प्रतीक है):

"firebase": "4.8.0", 

सहेजने के बाद, npm install मारा। अब, आपका आवेदन ठीक और चिकनी काम करेगा।

+1

आप guyz मेरी जिंदगी बचाया ... एक टन धन्यवाद। –

+1

यह मेरे लिए काम किया! बहुत बहुत धन्यवाद – TheAppchemist

0

यदि समस्या बनी रहती, मेरी शॉर्टकट सिर्फ खुला प्रदाताओं/firebase/firebase.ts, बस सभी सामग्री की प्रतिलिपि और उस पर फिर से पेस्ट करें .. कि यह firebase डेटाबेस के साथ ठीक से काम करेंगे अगर है अन्य कार्यक्रम पर कोई त्रुटि ।

अगर किसी के लिए भी यह ... यह शेयर स्थायी समाधान पता ..

0

किसी और को जो गूगल या कहीं और से इस सवाल के लिए आया था के लिए, AngularFire2 RC.6 नवीनतम firebase SDK के लिए पूर्ण समर्थन के साथ जारी की गई है। इसे लिखने के समय फायरबेस जावास्क्रिप्ट एसडीके v4.8.2, या v4.9.0 पर है। इस प्रश्न में प्रदान किया गया समाधान उस समय के लिए सही था। यदि आज इस प्रश्न से पूछा जाना था, तो जवाब Angularfire2 को Firebase v4.8.1 या उससे अधिक के साथ नवीनतम में अपग्रेड करना चाहिए।

यदि आपका निर्माण बिना किसी समस्या के चलता है, तो आप शायद विंडोज पर हैं। मुझे लगता है कि मैं मैक या लिनक्स मशीन एटीएम पर निर्माण करने में सक्षम नहीं हूं। मैं जल्द ही इसके बारे में एक प्रश्न पोस्ट कर दूंगा।

उम्मीद है कि यह किसी की मदद करेगा!

संबंधित मुद्दे